Author Topic: Electric Screen Conversion '03 model - High Beam and horn not working  (Read 2535 times)

atoyot

  • Guest
Hi,

Halfway through installing a David Silver supplied electric screen conversion, and it seems that there is a difference in the wiring and connectors supplied with this kit and the 03 wiring loom. The new switch has a hazard light switch, but the pass switch is integrated into the hi-lo switch. The problem that I have is that the pass switch works, but the high beam doesn't, neither does the horn.

Comparing the original switch block 6 pin connector to the Euro one supplied, there are some obvious differences, but has anyone solved this one before, and if so, what was the best way to fix it? I suspect re-using the original switch connector and re-wiring appropriately, but I'm not electrician by any stretch of the imagination!

Andrew
« Last Edit: September 03, 2012, 01:03:14 PM by atoyot »
 

Offline Shiney

  • Dave
  • Global Moderator
  • UNBELIEVABLE "5000 Posts" Member
  • *****
  • Posts: 6224
  • Thanked: 1867 times
  • RTE Coordinator - Strathpine, QLD
Re: Electric Screen Conversion '03 model - High Beam and horn not working
« Reply #1 on: September 03, 2012, 10:48:56 PM »
That sucks mate :'(
Unfortunately I donít know what the fix would be but :think1 if you upload some pictures some of the electrically savvy guys might be able to help :CB-- :thumb

Good luck
Shiney
My Ride: 2011 ST1300  :wht13
OzSTOC #104   STOC# 8512   IBA # 59142
Find me in The Who's Who of OzSTOC!

I like shiney things :grin
One of the Dave, Dave, Dave and Duncan crew 8)
 

Offline alans1100

  • 1999 ST1100A
  • UNBELIEVABLE "5000 Posts" Member
  • ****
  • Posts: 6250
  • Thanked: 1160 times
  • Alan, Peterborough, SA
Re: Electric Screen Conversion '03 model - High Beam and horn not working
« Reply #2 on: September 03, 2012, 11:29:05 PM »
I don't know enough about the 1300 but I understood the electric screen option was a standard issue on ABS versions

Is there a difference betwwen the ABS model LH switch block and the base model which allows the extra wiring for the screen operation?

1999 :bl11  2004 :13Candy

FarRider #921- BR15, BR17, CR1

 

atoyot

  • Guest
Re: Electric Screen Conversion '03 model - High Beam and horn not working
« Reply #3 on: September 04, 2012, 11:23:14 AM »
Just found a hint on the CalSci website that may require a mod on the switch, as the Euro switch has a few differences other than the screen and needs to be modified to work on US models. There is a hazard light switch where the pass switch is, and the pass switch is integrated with the hi-lo beam switch. From this, I assume that the US 03 model is the same as an Aust 03 model.

I think I'm on the right track, but I'll post a pic or 2, as Mark from Calcsi has requested some pics as well. Just seems that if the switch can just be re-wired here, it would be better than sending mine to the US to be modded and sent back.

The alternative would just be to take it to an auto electrician with siring diagrams of the Euro, ABS and Std model and get them to work out what should go where.

regards

Andrew
 

atoyot

  • Guest
Re: Electric Screen Conversion '03 model - High Beam and horn not working
« Reply #4 on: September 04, 2012, 11:30:51 PM »
I just got a reply from Mark at Calsci, and from my photos, the switch is already converted, so back to square one! May need a visit to a sparky. :(

Andrew
 

atoyot

  • Guest
Re: Electric Screen Conversion '03 model - High Beam and horn not working
« Reply #5 on: September 05, 2012, 01:53:38 PM »
All sorted. It seems that the Euro/US LH switch blocks have reversed the white/green and dark blue wires in their switches for some reason. Not sure if that means theres a difference in their main looms, but I just swapped the female pins on the bike loom to match the switch connector colors and now I have a horn and hi-beam!

Many thanks  :thumbsup to Mark at Calsci for his assistance, and I haven't even bought anything off him.......yet