Author Topic: Incorrect fuel indicator reading  (Read 173 times)

Offline Flat White

  • Newbie
  • *
  • Posts: 3
  • ST Legend
Incorrect fuel indicator reading
« on: July 04, 2018, 08:48:44 AM »
Replaced the top petrol tank sender unit in my ST1300 since the bottom tank sender unit still works on reserve only to find no change to the consistent 3 bar instrument display. It's not the sender unit. I'm hoping it's a computer glitch. Anyone had this problem before? Any suggestions?
 

Online richo

  • Richo
  • Legendary Member
  • *****
  • Posts: 634
  • Thanked: 216 times
  • ST 2009
Re: Incorrect fuel indicator reading
« Reply #1 on: July 04, 2018, 09:08:32 AM »
 :popcorn. My fuel guage only goes down to two bars so interested in responses for this
Richo
 

Online Shiney

  • Dave
  • Global Moderator
  • UNBELIEVABLE "5000 Posts" Member
  • *****
  • Posts: 5463
  • Thanked: 1315 times
  • RTE Coordinator - Strathpine, QLD
Re: Incorrect fuel indicator reading
« Reply #2 on: July 06, 2018, 08:14:01 PM »
:think1 Does it show 3 bars all the time, does it build up or change at any time?
My Ride: 2015 (Model) ST1300  :wht13
OzSTOC #104   STOC# 8512   IBA # 59142
Find me in The Who's Who of OzSTOC!

I like shiney things :grin
One of the Dave, Dave, Dave and Duncan crew 8)
 

Offline Flat White

  • Newbie
  • *
  • Posts: 3
  • ST Legend
Re: Incorrect fuel indicator reading
« Reply #3 on: July 07, 2018, 10:33:58 AM »
3 bars all the time irrespective of a full or empty top tank.
 

Online StinkyPete

  • Defected to a BMW
  • NR2016 Group
  • UNBELIEVABLE "5000 Posts" Member
  • *
  • Posts: 5019
  • Thanked: 1293 times
  • Blackwood, SA
Re: Incorrect fuel indicator reading
« Reply #4 on: July 07, 2018, 10:52:33 AM »
All I can suggest is an "ECU Reset" as described here...   http://ozstoc.com/index.php?topic=11334.msg1208817#msg1208817  having first checked  the connections on the top of the sub-tank.

There might be a gremlin in the system that this will chase away.
IBA #59146    FarRider #834    OzLapper
             "Riding the Long Roads"
 

Offline Flat White

  • Newbie
  • *
  • Posts: 3
  • ST Legend
Re: Incorrect fuel indicator reading
« Reply #5 on: July 07, 2018, 10:58:29 AM »
Thanks for that.